RIP – Routing Information Protocol

Протокол маршрутной информации — один из самых простых протоколов маршрутизации. Применяется в небольших компьютерных сетях, позволяет маршрутизаторам динамически обновлять маршрутную информацию (направление и дальность в хопах), получая ее от соседних маршрутизаторов.

RIP — так называемый протокол дистанционно-векторной маршрутизации, который оперирует транзитными участками в качестве метрики маршрутизации. Максимальное количество хопов, разрешенное в RIP — 15 (метрика 16 означает «бесконечно большую метрику»). Каждый RIP-маршрутизатор по умолчанию вещает в сеть свою полную таблицу маршрутизации раз в 30 секунд, довольно сильно нагружая низкоскоростные линии связи. RIP работает на 3 уровне (сетевой) стека TCP/IP, используя UDP порт 520.

В современных сетевых средах RIP — не самое лучшее решение для выбора в качестве протокола маршрутизации, так как его возможности уступают более современным протоколам, таким как EIGRP, OSPF. Ограничение на 15 хопов не дает применять его в больших сетях. Преимущество этого протокола — простота конфигурирования.

Приступаем.

image_1

Положительным результатом будем считать наличие нужных маршрутов в таблице маршрутизации и Ping между хостами.

Начнем настройку. Запускаем наши роутеры, настраиваем интерфейсы и IP – адреса, согласно схеме.

Router_1>en
Router_1#conf t
Router_1(config)#int fa 0/0
Router_1(config-if)#ip address 172.16.10.1 255.255.255.0
Router_1(config-if)#description To_host
Router_1(config-if)#no sh
Router_1(config-if)#int ser 0/0
Router_1(config-if)#ip address 172.16.20.1 255.255.255.252
Router_1(config-if)#description To_Router_2
Router_1(config-if)#no sh
Router_1(config-if)#exit
Router_1(config)#^Z
Router_1#wr

R2>en
R2#conf t
R2(config)#hostname Router_2
Router_2(config)#int fa 0/0
Router_2(config-if)#ip address 172.16.30.1 255.255.255.0
Router_2(config-if)#description To_host
Router_2(config-if)#no sh
Router_2(config-if)#int ser 0/0
Router_2(config-if)#ip address 172.16.20.2 255.255.255.252
Router_2(config-if)#no sh
Router_2(config-if)#description To_Router_2
Router_2(config-if)#int ser 0/1
Router_2(config-if)#ip address 172.16.40.1 255.255.255.252
Router_2(config-if)#no sh
Router_2(config-if)#description To_Router_3
Router_2(config-if)#exit
Router_2(config)#^Z
Router_2#wr
R3>en

R3#conf t
R3(config)#hostname Router_3
Router_3(config)#int fa 0/0
Router_3(config-if)#ip address 172.16.50.1 255.255.255.0
Router_3(config-if)#no sh
Router_3(config-if)#description To_host
Router_3(config-if)#int ser 0/1
Router_3(config-if)#ip address 172.16.40.2 255.255.255.252
Router_3(config-if)#description To_Router_2
Router_3(config-if)#no sh
Router_3(config-if)#exit
Router_3(config)#^Z
Router_3#wr

Проверим сетевую доступность между роутерами ping-ом – все работает.

Теперь, проверим доступность роутеров с конечных хостов и отсутствие (на данный момент) сетевой доступности между хостами. Как видно, роутеры пингуются, а вот между хостами связи нет. Давайте, это исправим.

Заходим по очереди на роутеры и делаем следующие настройки:

Router_1#conf t
Router_1(config)#router rip – заходим в режим настройки RIP
Router_1(config-router)#version 2 – выбираем версию 2
Router_1(config-router)#network 172.16.0.0 – добавляем сеть
Router_1(config-router)#no auto-summary - отключаем автосуммаризацию
Router_1(config-router)#exit
Router_1(config)#exit
Router_1#wr

Router_2#conf t
Router_2(config)#router rip
Router_2(config-router)#version 2
Router_2(config-router)#network 172.16.0.0
Router_2(config-router)#no auto-summary
Router_2(config-router)#exit
Router_2(config)#exit
Router_2#wr

Router_3#conf t
Router_3(config)#router rip
Router_3(config-router)#version 2
Router_3(config-router)#network 172.16.0.0
Router_3(config-router)#no auto-summary
Router_3(config-router)#exit
Router_3(config)#exit
Router_3#

Надо помнить, что добавление сетей в процесс RIP осуществляется заданием classful network, а не подсетью. То есть правильно 172.16.0.0, а не 172.16.10.0.

Для детальных настроек RIP существуют еще команды. Вот некоторые из них:

Router(config-router)#no network w.x.y.z – удаляет сеть из процесса PIR;
Router(config-router)#version 1 – включает RIP версии 1;
Router(config-router)#passive-interface s0/0/0 – выключает посылку обновлений RIP на заданном интерфейсе (по умолчанию, рассылка обновлений включается на всех интерфейсах);
Router(config-router)#timers basic <> - позволяет задавать таймеры обновлений, время отклика и так далее…;
Router#debug ip rip – отображает всю информацию о работе протокола RIP в реальном времени;
Router#show ip rip database – отображает содержимое базы данных ( информации о маршрутах);

Leave a Reply

Your email address will not be published. Required fields are marked *